Search found 15 matches

by panlab_mf
Fri Jul 19, 2019 7:09 am
Forum: RVMedia
Topic: RVmedia adn ONVIF Standard
Replies: 3
Views: 6328

Re: RVmedia adn ONVIF Standard

Hi All,

Any news regarding ONVIF support plans?

Regards,
by panlab_mf
Wed Jul 17, 2019 3:08 pm
Forum: RVMedia
Topic: RVMedia 6 and RTSP - Authentication problems
Replies: 1
Views: 386

RVMedia 6 and RTSP - Authentication problems

Hi all, I'm dealing some issues with RTSP connection event with RVMedia v6. I have to kind of cameras, a) lazy(weak) secured; b) strongly secured. If I connect to the a) kind of cameras, I'm able to receive the video streaming just using the external method (ffmpeg library; TRVMFFMPEG.OpenFile; TRVM...
by panlab_mf
Wed Jul 03, 2019 10:40 am
Forum: RVMedia
Topic: AV on TRVMFFMPEG.InitDecode
Replies: 2
Views: 836

Re: AV on TRVMFFMPEG.InitDecode

Nice.
by panlab_mf
Mon Jul 01, 2019 2:53 pm
Forum: RVMedia
Topic: AV on TRVMFFMPEG.InitDecode
Replies: 2
Views: 836

AV on TRVMFFMPEG.InitDecode

Hi, I'm getting AV on TRVMFFMPEG.InitDecode(), if the OpenFile returns false. try // Open video file if not OpenFile(FormatContext, DecCurTime, filename) then begin try av_free(FormatContext); finally FormatContext := nil; end; exit; end; except exit; end; How can I silence this exception in order t...
by panlab_mf
Mon Jul 01, 2019 2:45 pm
Forum: RVMedia
Topic: AV on MRVTypesThreads.GetGUIDInfoWithCreate
Replies: 1
Views: 510

AV on MRVTypesThreads.GetGUIDInfoWithCreate

Hi,

It seems in MRVTypesThreads.GetGUIDInfoWithCreate() needs checking for the ListGUID variable before use it, as it is already done in the other routines in the same unit:

Code: Select all

  if not Assigned(ListGUID) then
    exit;
 
Don't you think?

Best regards.
by panlab_mf
Fri Jun 28, 2019 8:07 am
Forum: RVMedia
Topic: RVMedia 6 and RTSP - Network problems
Replies: 9
Views: 3099

Re: RVMedia 6 and RTSP - Network problems

Hi Sergey,

Ok, I will wait for the public beta or the final relase, whatever comes first.

Best regards,
by panlab_mf
Thu Jun 13, 2019 8:13 am
Forum: RVMedia
Topic: RVMedia 6 and RTSP - Network problems
Replies: 9
Views: 3099

Re: RVMedia 6 and RTSP - Network problems

Hi all, I'm dealing the same issues, more or less. I let the user to edit the url to connect to in a showmodal dialog, if the url is ok the application shows a preview of the camera. When the user accepts the configuration dialog, the connection is closed. //camera is working. Video and images can b...
by panlab_mf
Mon Apr 08, 2019 2:14 pm
Forum: RVMedia
Topic: Missing last frames
Replies: 6
Views: 3447

Re: Missing last frames

I'm going to test it lowering the frame rate from 25 FPS to 15 FPS. And let you know.
by panlab_mf
Mon Apr 08, 2019 9:52 am
Forum: RVMedia
Topic: Missing last frames
Replies: 6
Views: 3447

Re: Missing last frames

Hi All, I'm facing the same issue, more or less. In my case there is no audio source. I've tried several convinations : file formats; video codecs; local/remote cameras; frame rate with the same result: the recorded video file missing almost 2 second of recording. I've added some debugging options t...
by panlab_mf
Thu Feb 14, 2019 3:53 pm
Forum: RVMedia
Topic: LoadFFMpegLibraries fails for a specific path
Replies: 3
Views: 1871

Re: LoadFFMpegLibraries fails for a specific path

Hi all Using "Dependency Walker" v2.2.6000 that's what I've found: avcodec-58: swresample-3 avutil-56 avformat-58: avcodec-58 avutil-56 avutil-56: swresample-3: avutil-56 swscale-3: avutil-56 So, it seems than the right order to load the dlls could be: avutil-56, swscale-3, swresample-3, avcodec-58,...
by panlab_mf
Thu Feb 14, 2019 2:47 pm
Forum: RVMedia
Topic: LoadFFMpegLibraries fails for a specific path
Replies: 3
Views: 1871

Re: LoadFFMpegLibraries fails for a specific path

Hi all, After a few research about DLL loading. I've tryed to help the default mechanism to find out the dll into the subfolder, changing the PATH enviroemtn variablelike this: [spoiler]initialization if not init_ffmpeg then begin sEnvPath := GetEnvironmentVariable('PATH'); sEnvPath := '.\bin32\' + ...
by panlab_mf
Thu Feb 14, 2019 2:24 pm
Forum: RVMedia
Topic: LoadFFMpegLibraries fails for a specific path
Replies: 3
Views: 1871

LoadFFMpegLibraries fails for a specific path

Hi all, Im trying to load the ffmpegs x64 libraries from a sub folder of my application, for instance, '.\bin64\', using the LoadFFMpegLibraries(). But it fails what ever I do the call. I'm using the "ffmpeg" demo project. So, if I copy the dlls into the same direcoty as the final executable, the de...
by panlab_mf
Tue Feb 12, 2019 9:47 am
Forum: RVMedia
Topic: RVMedia v6.1 vs ffmpeg 4.x 64bits
Replies: 4
Views: 2003

Re: RVMedia v6.1 vs ffmpeg 4.x 64bits

Greate. Nice work, guys!

Yes, please! You can send the fixed source files to the email address specified in my forum profile.

Best regards.
by panlab_mf
Mon Feb 11, 2019 11:22 am
Forum: RVMedia
Topic: RVMedia v6.1 vs ffmpeg 4.x 64bits
Replies: 4
Views: 2003

Re: RVMedia v6.1 vs ffmpeg 4.x 64bits

Ok. What I can see is that the AV is internal, by means, if I debug deeper using the CPU Debug window, the AV raises after many code is running in the avformat-58.dll. My guess is because the AVContextFormat for 4.x is partially translated. the fast way to repodruce it is compiling the "ffmpeg" demo...
by panlab_mf
Wed Feb 06, 2019 10:08 am
Forum: RVMedia
Topic: RVMedia v6.1 vs ffmpeg 4.x 64bits
Replies: 4
Views: 2003

RVMedia v6.1 vs ffmpeg 4.x 64bits

Hi all, I'm testing the RVMediaDemosX7Plus in win64 platform. But it crash we run the "ffmpeg" demo because the ffmpeg version that I already have for others projects is v4.1. It works for win32, but it seems the header has changed so it raises an exception when try to access the av_xxx routines. I'...