Search found 55 matches

by Pieter E.
Wed Jun 11, 2008 5:17 pm
Forum: Support
Topic: In Vista, Office converter is not importing *.doc file
Replies: 5
Views: 7634

I'm using Vista Business SP1, C++ Builder 2007, MS Office 2007 SP1, TRichViewEdit v1.9.46 and TRVOfficeConverter without any problems. The following source works: OpenDialog1->Filter = "RTF files|*.rtf|" + rvc->GetImportFilter(); if(OpenDialog1->Execute()) { rve->Clear(); rve->Format(); rve->Update(...
by Pieter E.
Tue Mar 25, 2008 2:01 pm
Forum: Support
Topic: Picture Alignment...again ;-)
Replies: 18
Views: 18206

I was wondering if 'picture alignment' is still on your to-do-list? If so, when is this function ready?

Thanks for your response.
by Pieter E.
Sun Mar 02, 2008 12:36 pm
Forum: Support
Topic: Always unable to export to MS Word
Replies: 39
Views: 42531

Could OLE Automation be a temporary solution?
by Pieter E.
Wed Feb 20, 2008 6:06 pm
Forum: Support
Topic: LiveSpelling problem
Replies: 13
Views: 8544

You should close/stop the Live Spellchecker before closing. I had the same problems a long time ago.
by Pieter E.
Tue Jan 02, 2007 7:31 am
Forum: Support
Topic: A happy new year to all
Replies: 2
Views: 3856

Happy New Year! :P
by Pieter E.
Mon Dec 18, 2006 3:52 pm
Forum: Support
Topic: Problem using RichView with LiveSpelling (MS Word)?
Replies: 6
Views: 7605

Thank you for your answer. But this doesn't look like a LIVE spellcheck. Thanks anyway :wink:
by Pieter E.
Fri Dec 15, 2006 4:17 pm
Forum: Support
Topic: Problem using RichView with LiveSpelling (MS Word)?
Replies: 6
Views: 7605

@Primoz:
Could you please explain how you've implemented a Live Spelling using MS Word?

Thanks in advance!
by Pieter E.
Tue Oct 31, 2006 8:14 pm
Forum: Support
Topic: No exported image when cell is still edited
Replies: 5
Views: 7518

Dear Sergey, I've noticed the same problem when a tablecell contains an image and the cursor is still there, the image could not be taken. I think the problem is in the 'OnSaveImage2'-event. I use this event for converting the 'Graphic' to a 'MIMEEncodeString' for sending as an e-mail. [edit] Adding...
by Pieter E.
Thu Sep 21, 2006 11:47 am
Forum: Support
Topic: Please do IMG ALIGN next
Replies: 14
Views: 12142

Floating images will be implemented after <img align=left/right>
Can you give us a date or is it on your to do list?
by Pieter E.
Mon Sep 18, 2006 10:49 am
Forum: Support
Topic: Please do IMG ALIGN next
Replies: 14
Views: 12142

Maybe you could add a poll for the most important functionalities.

I prefer the image alignment also!
by Pieter E.
Fri Sep 15, 2006 7:08 am
Forum: Examples, Demos
Topic: [Component] Using Shockwave Flash ActiveX in RichView
Replies: 22
Views: 227183

Could you please post a compiled project using the 'TMyShockwaveFlash'-class and a Flash Movie? I'm trying to create a way to handle Flash Movies using C++ Builder. (When you post a compiled project I can compare your version with mine and figure out if it's working properly.)
by Pieter E.
Mon Sep 11, 2006 5:32 pm
Forum: Support
Topic: Problem inserting TComboBox and TListBox in richviewedit
Replies: 2
Views: 4349

Did you register the 'TComboBox'-class before inserting using 'RegisterClasses'? You set the owner of the 'TListBox' to 'self'. Maybe it is better to typecast nihil to a 'TComponent'. In C++ it look like this: Call this once: TComponentClass Classes[1] = { __classid(TComboBox }; RegisterClasses(Clas...
by Pieter E.
Thu Jun 22, 2006 3:56 pm
Forum: Support
Topic: Clicking a table cell causes OnItemAction to fire
Replies: 8
Views: 9682

I understand. Is there a way to recognize if a picture is nested in a table? My application uses 'rviaInserted' for recognizing new added pictures. A picture which already is inserted shouldn't be recognized.
by Pieter E.
Thu Jun 22, 2006 6:21 am
Forum: Support
Topic: Clicking a table cell causes OnItemAction to fire
Replies: 8
Views: 9682

When I insert a picture the 'rviaInserted' is used. Like it should be. But when I select a picture which is nested in a table the 'rviaInserted' is also used. When a picture is outside a table and I select it, the 'rviaInserted' is not used.

Try it out adding a 'messagebox' in the 'rviaInserted'.
by Pieter E.
Wed Jun 21, 2006 8:32 am
Forum: Support
Topic: Clicking a table cell causes OnItemAction to fire
Replies: 8
Views: 9682

Dear Sergey, I found the same problem when a picture is nested in a table the rviaInserted is used while the picture isn't inserted by the user. I use the following sourceparts: rve->RVFOptions = rve->RVFOptions >> rvfoSavePicturesBody >> rvfoSaveBack; ONRVFPictureNeeded event for loading images fro...