Snapshot always saves the image from first camera

New product: VCL components for displaying and controlling IP cameras, webcams, video conferencing, video chats
Post Reply
hassan
Posts: 1
Joined: Tue Dec 11, 2012 2:13 am
Location: Vancouver, Canada

Snapshot always saves the image from first camera

Post by hassan » Fri Jul 22, 2016 4:43 pm

I am using RVMedia (registered) 5.0.1. It always saves the snapshot of the first camera (such as local webcam). You can easily test the issue by using your compiled “MediaTest.exe”:
1. Launch Mediatest.exe
2. Choose another camera from camera list such as “Live c-cam” and then
3. click on “SnapShot…” and save the file
4. You can see that saved file is not the correct snapshot of the camera (and if you do not have local webcam, it will have zero byte size)

Thanks

Sergey Tkachenko
Site Admin
Posts: 13586
Joined: Sat Aug 27, 2005 10:28 am
Contact:

Post by Sergey Tkachenko » Sat Jul 23, 2016 11:06 am

We confirm the bug, a fixed unit will be sent by email

mihoum
Posts: 5
Joined: Tue Apr 14, 2009 3:59 pm

Post by mihoum » Mon Jul 25, 2016 3:38 pm

We received the fixed unit MRVThreads.pas, but the it cannot be compiled.

[dcc32 Error] MRVThreads.pas(381): E2003 Undeclared identifier: 'MAX_BUFFER_SIZE'
[dcc32 Error] MRVThreads.pas(771): E2003 Undeclared identifier: 'MAX_BUFFER_SIZE'
[dcc32 Error] MRVThreads.pas(910): E2003 Undeclared identifier: 'VideoEncodeFrame'

mihoum
Posts: 5
Joined: Tue Apr 14, 2009 3:59 pm

Post by mihoum » Mon Jul 25, 2016 5:03 pm

Thank you for the final update. It works as expected now.

Sergey Tkachenko
Site Admin
Posts: 13586
Joined: Sat Aug 27, 2005 10:28 am
Contact:

Post by Sergey Tkachenko » Mon Jul 25, 2016 6:28 pm

The previous version sent to you included changes we made for implementing video and audio encoding. We reverted them temporarily to send a fixed version of the unit.

Post Reply