Snapshot from an axis ip camera stream doesn't work

New product: VCL components for displaying and controlling IP cameras, webcams, video conferencing, video chats
Post Reply
Philipm2
Posts: 2
Joined: Wed May 24, 2017 12:28 pm

Snapshot from an axis ip camera stream doesn't work

Post by Philipm2 » Wed May 24, 2017 12:41 pm

I have a registered version of RVMedia. I can connect to both USB webcams and axis image server streams as expected. Both streams are visible in the viewer component. However, I can only take snapshots from USB webcams. GetBitmap will also only work with USB webcams. I do not want to record at the full frame rate. Is there some othe way to extract frames periodically from an axis ip camera stream?

Sergey Tkachenko
Site Admin
Posts: 13586
Joined: Sat Aug 27, 2005 10:28 am
Contact:

Re: Snapshot from an axis ip camera stream doesn't work

Post by Sergey Tkachenko » Thu May 25, 2017 11:40 am

Do you have a viewer connected to this camera? If video from camera is not displayed or is not sent further, the component does not decode frames.
A workaround is assigning empty event handler for TRVCamera.OnGetImage event

Philipm2
Posts: 2
Joined: Wed May 24, 2017 12:28 pm

Re: Snapshot from an axis ip camera stream doesn't work

Post by Philipm2 » Thu May 25, 2017 1:09 pm

Thanks for your quick response. I do have a viewer connected and it works correctly for both the USB webcams and the axis image server. Getsnapshot provides excactly the functionality I need but I'll look at implementing something based on the new image event.

Sergey Tkachenko
Site Admin
Posts: 13586
Joined: Sat Aug 27, 2005 10:28 am
Contact:

Re: Snapshot from an axis ip camera stream doesn't work

Post by Sergey Tkachenko » Thu May 25, 2017 6:03 pm

Snapshots will be ok in the next version that we will upload soon. Until then, please use this event.

Post Reply