How to disable spelling check

General TRichView support forum. Please post your questions here
Post Reply
Cianogen
Posts: 2
Joined: Thu Mar 23, 2017 10:32 am

How to disable spelling check

Post by Cianogen » Thu Mar 23, 2017 10:42 am

I'm trying with last demo disabling spelling check.

Code: Select all

RVdxSpellChecker1.CheckAsYouTypeOptions.Active := False;
  RVdxSpellChecker1.UpdateRules;
  cxTRichViewEdit1.InnerEditor.ClearLiveSpellingResults;
But it doesn't work, like it works with DevExress controls.
After execution of code above, the red wave lines disappear, but if you type any char they became visible.

Cianogen
Posts: 2
Joined: Thu Mar 23, 2017 10:32 am

Re: How to disable spelling check

Post by Cianogen » Fri Mar 24, 2017 12:00 am

I See only one solution, make free all dictionary's from RvDxSpellChecker1 and then free RvDxSpellChecker1.
What do you think about it? It's seems to be a noobish solution but I can't find alternative :shock:

Sergey Tkachenko
Site Admin
Posts: 14515
Joined: Sat Aug 27, 2005 10:28 am
Contact:

Re: How to disable spelling check

Post by Sergey Tkachenko » Fri Mar 24, 2017 8:27 am

Yes, the current version of TRvDxSpellChecker always checks TcxTRichViewEdit controls, ignoring CheckAsYouTypeOptions.Active.
It will be fixed in the next update (planned in the beginning of the next week).

Due some reasons, it's quite tricky to stop checking while TcxTRichViewEdit is already being checked, so I'll add a new method
TRvDxSpellChecker.StopLiveSpelling
To start checking again, you will need to assign CheckAsYouTypeOptions.Active := True.

Post Reply