Page 1 of 1

Missing icons in ReportBuilder 20.02

Posted: Fri Feb 14, 2020 8:18 am
by GoranBru
Hello,
I have updated the ReportBuilder from version 19.03 to 22.02 yesterday and after that I reruned the installation for TRichView and I don't see the components for TppRichView and TppDBRichView in the ReportDesigner anymore. To be sure I just reruned the installation and I see in the listbox:
"Installing optional integration in ReportBuilder... Skipped."
What can I do to bring back the components to RB designer? I use RB 20.02, TRichView 19.03 and the TScaleRichView 9.0.3

Best regards,
Goran

Re: Missing icons in ReportBuilder 20.02

Posted: Fri Feb 14, 2020 6:26 pm
by Sergey Tkachenko
How did you reinstall TRichView? After a major ReportBuilder update, it's not enough to run "Install TRichView in Delphi IDE" from the Start menu. You need to re-run the full TRichView setup (because it needs to recreate packages for ReportBuilder wrapper for the changed major version of ReportBuilder).

Re: Missing icons in ReportBuilder 20.02

Posted: Mon Feb 17, 2020 7:26 am
by GoranBru
Hi Sergey,
I started the application "Install TRichView in Delphi IDE", then selected "Install or modify" and that is it. Should I remove TScaleRichView and then also TRichView and then install both of them?

Re: Missing icons in ReportBuilder 20.02

Posted: Mon Feb 17, 2020 7:34 am
by GoranBru
Hi Sergey,
Your question made me thinking so I opened projects RvRbD10_1.dproj and RvRbD10_1_Dsgn.dproj, modified the lines pointing to rbIDE*, rbRCL* and rbRTL* to the correct files (in my case rbIDE2024 etc), rebuild, compiled and installed the later one. Now I have those icons back. Thanks!