Search found 64 matches

by ya_vanka
Fri Aug 28, 2020 7:48 am
Forum: RVMedia
Topic: Video stream error on trying to open udp://127.0.0.1:54000
Replies: 22
Views: 19893

Re: Video stream error on trying to open udp://127.0.0.1:54000

Tested update, but I still have a big delay and video frame corruption.

I found out that my video source sends data in tiny blocks (188 bytes).
Can this be the reason of the delay and corruption?
by ya_vanka
Thu Aug 20, 2020 11:53 am
Forum: RVMedia
Topic: How to avoid copying frame bitmap and use pointer to data instead
Replies: 0
Views: 3248

How to avoid copying frame bitmap and use pointer to data instead

Got one more question. At some moment this update was done: https://www.trichview.com/forums/viewtopic.php?p=36950#p36950 This should have made possible not to copy frame bitmap. I have a working code: FLastFrame: TRVMBitmap; procedure TVideoDlgForm2.RVCamera1GetImage(Sender: TObject; img: TRVMBitma...
by ya_vanka
Wed Aug 19, 2020 7:43 pm
Forum: RVMedia
Topic: Video stream error on trying to open udp://127.0.0.1:54000
Replies: 22
Views: 19893

Re: Video stream error on trying to open udp://127.0.0.1:54000

Great!

Waiting for this update.
by ya_vanka
Mon Aug 17, 2020 1:33 pm
Forum: RVMedia
Topic: Video stream error on trying to open udp://127.0.0.1:54000
Replies: 22
Views: 19893

Re: Video stream error on trying to open udp://127.0.0.1:54000

And the problem is that "-probesize 64" affects greately on video latency.
by ya_vanka
Mon Aug 17, 2020 12:07 pm
Forum: RVMedia
Topic: Video stream error on trying to open udp://127.0.0.1:54000
Replies: 22
Views: 19893

Re: Video stream error on trying to open udp://127.0.0.1:54000

In order to set additional params (-framedrop -sync video -fflags nobuffer -probesize 64) I've written the following procedure: function SetDictSpeedUpOptions(var AOptionsDict : PAVDictionary): Boolean; var v: PAnsiChar; begin Result := (av_dict_set(AOptionsDict, 'framedrop', nil, 0) = 0); v := PAns...
by ya_vanka
Sat Aug 15, 2020 4:11 pm
Forum: RVMedia
Topic: Video stream error on trying to open udp://127.0.0.1:54000
Replies: 22
Views: 19893

Re: Video stream error on trying to open udp://127.0.0.1:54000

Well, may be periodically smth is distorted.
But in my case picture becomes corrupted in 30 seconds from start and then never restores.

Watch please this: https://yadi.sk/i/vNDmBlwFdEB8Mg and this: https://yadi.sk/d/VmxWkiIt0JuwXA
by ya_vanka
Fri Aug 14, 2020 2:31 pm
Forum: RVMedia
Topic: Video stream error on trying to open udp://127.0.0.1:54000
Replies: 22
Views: 19893

Re: Video stream error on trying to open udp://127.0.0.1:54000

Can video frame corruption be reproduced reliably? Yes. Do you have the same results with ffplay? No. FFPlay shows without corruption. Probably, the reason is in UDP protocol. It does not guarantee that data are delivered correctly. If the sender was on a remote PC - yes. But it is on the same PC (...
by ya_vanka
Fri Aug 14, 2020 2:13 pm
Forum: RVMedia
Topic: Video stream error on trying to open udp://127.0.0.1:54000
Replies: 22
Views: 19893

Re: Video stream error on trying to open udp://127.0.0.1:54000

And the second problem is the latancy of 2-2.5 seconds. I get the same or even bigger latency if I use ffplay cmd: ffplay.exe -i udp://127.0.0.1:54000 It can be reduced to 0.1 sec by the following cmd: ffplay.exe -i udp://127.0.0.1:54000 -framedrop -sync video -fflags nobuffer -probesize 64 How can ...
by ya_vanka
Fri Aug 14, 2020 2:00 pm
Forum: RVMedia
Topic: Video stream error on trying to open udp://127.0.0.1:54000
Replies: 22
Views: 19893

Re: Video stream error on trying to open udp://127.0.0.1:54000

So, since version 7.5 I get video, but in a minute it's getting corrupted. First 30 seconds image: mediatest_1.jpg And then this: mediatest_2.jpg And this: mediatest_3.jpg And this: mediatest_4.jpg What is the reason of this corruption? FFMpegProperties are set by default except for Audio=false.
by ya_vanka
Thu Aug 13, 2020 10:52 am
Forum: RVMedia
Topic: Video stream error on trying to open udp://127.0.0.1:54000
Replies: 22
Views: 19893

Re: Video stream error on trying to open udp://127.0.0.1:54000

Good news!
Going to upgrade and test!
by ya_vanka
Wed Aug 12, 2020 8:27 am
Forum: RVMedia
Topic: Video stream error on trying to open udp://127.0.0.1:54000
Replies: 22
Views: 19893

Re: Video stream error on trying to open udp://127.0.0.1:54000

Thanks!
Finally I've got video.

Can I set timeout to 0 instead of assigning RVCamera.FFMpegProperty.UseFFmpegProperty = False?
by ya_vanka
Sun Aug 09, 2020 7:42 pm
Forum: RVMedia
Topic: Video stream error on trying to open udp://127.0.0.1:54000
Replies: 22
Views: 19893

Re: Video stream error on trying to open udp://127.0.0.1:54000

Tried to set RVCamera.FFMpegProperty.UseFFmpegProperty = False to all cameras in MediaTest application, but the result is the same (video stream error).
Did you use this demo project for test or some other?
by ya_vanka
Thu Aug 06, 2020 3:55 pm
Forum: RVMedia
Topic: Video stream error on trying to open udp://127.0.0.1:54000
Replies: 22
Views: 19893

Re: Video stream error on trying to open udp://127.0.0.1:54000

I get the same error if I try to stream the file (https://yadi.sk/i/6Gr0hRuHFAlhJw) via vlc
:sout=#udp{dst=127.0.0.1:1234} :no-sout-all :sout-keep

ffplay.exe -i udp://127.0.0.1:1234 shows video
mediatest gets video stream error

Could you please check it and find a solution?