Search found 7 matches

by SkyX
Sat Feb 22, 2020 2:11 am
Forum: RVMedia
Topic: RVMedia 6 and RTSP - Network problems
Replies: 41
Views: 12246

Re: RVMedia 6 and RTSP - Network problems

Compiled project10 plays video immediately.
Ok, probably it is my local problem. Thx.
by SkyX
Fri Feb 21, 2020 4:36 am
Forum: RVMedia
Topic: RVMedia 6 and RTSP - Network problems
Replies: 41
Views: 12246

Re: RVMedia 6 and RTSP - Network problems

Sergey, Hi. This post scarcely related to this topic. I have a little trouble with 7.2 version: After first calling PlayVideoStream nothing happens (for http, rtsp and local files). After Abort and secondary calling PlayVideoStream all works fine. You can download example from this post https://www....
by SkyX
Sun Dec 22, 2019 2:14 am
Forum: RVMedia
Topic: RVMedia 6 and RTSP - Network problems
Replies: 41
Views: 12246

Re: RVMedia 6 and RTSP - Network problems

Nice! Big thx, Sergey!
by SkyX
Thu Dec 19, 2019 10:07 am
Forum: RVMedia
Topic: RVMedia 6 and RTSP - Network problems
Replies: 41
Views: 12246

Re: RVMedia 6 and RTSP - Network problems

UPD 3: My experiments with old versions of RVMedia and old unknown version of FFMpeg files: avcodec-56.dll avdevice-56.dll avfilter-5.dll avformat-56.dll avutil-54.dll swresample-1.dll swscale-3.dll Results: RVMedia 6.1 - close connections RVMedia 5.X (maybe 5.3) - close connections RVMedia 5.0.1 do...
by SkyX
Thu Dec 19, 2019 5:36 am
Forum: RVMedia
Topic: RVMedia 6 and RTSP - Network problems
Replies: 41
Views: 12246

Re: RVMedia 6 and RTSP - Network problems

Here is source code of small application: https://drive.google.com/open?id=1vExqvu_8HpC55tDTSudXoopTeTSBQkWU This shows an even more severe bug with disabling sockets after a single start of local file playback. Somewhere inside the component sockets or something else are crashing. Re-initialization...
by SkyX
Wed Dec 18, 2019 4:11 pm
Forum: RVMedia
Topic: RVMedia 6 and RTSP - Network problems
Replies: 41
Views: 12246

Re: RVMedia 6 and RTSP - Network problems

UPD: I replaced avformat_close_input(pFormat_context); with avformat_free_context(pFormat_context); in MRVFFMPEGObject like @mitzi sayd few days ago. In my project problem solved with http connection, but with rtsp connection after three times aborting video disappears but after 2-3 minutes waiting ...
by SkyX
Wed Dec 18, 2019 2:27 pm
Forum: RVMedia
Topic: RVMedia 6 and RTSP - Network problems
Replies: 41
Views: 12246

Re: RVMedia 6 and RTSP - Network problems

Hello! The problem has not yet been identified? Today I was doing the final testing of my program and got a very similar problem. After 3 times RVCamera aborting, FireDAC close remote database connection! It is really big problem. FFmpeg used with rtsp and http connections to IP cameras. When I use ...