strange problems

ScaleRichView support and discussion (TRichView add-on for WYSIWYG editing)
Post Reply
toolwiz
Posts: 150
Joined: Wed Nov 30, 2005 3:27 am

strange problems

Post by toolwiz » Tue Apr 08, 2008 12:11 am

I'm running into some strange problems. I'm sorry but I can only describe the symptoms in very general terms.

Here's the context: someone is importing a Word .doc file into SRV using the latest converter (Word 97-2003 Document). In general, it's working fine.

However, there are situations people have reported and I've observed where a page is added and some very short lines are added that contain hyperlinks. Something like this:

=====================================
Check out the Google search engine

http://www.google.com
=====================================

These lines are usually CENTERED (not left-aligned).

Within Word, everything is just fine.

What happens after the import is that the internal data structures are totally fractured for the RV Items on this page!

The embedded link in the first line looks blue with underscore, but it's not a hyperlink. The second one may or may not even be recognized as a hyperlink.

There should normally be three RV Items on the first line and one on the second. But I've seen ten or more different items for this little bit of text! And they're all messed up. Some overlap, they change styles, font faces, etc.

When this bit of text gets run through llionPDF, it usually doesn't result in useful hyperlinks, even thought it does look ok on the page. However, the text on pages before and after it is just fine.

This doesn't seem to happen on a one-page document. Rather, if you've got a multi-page document and you add a page between two, or at the end, and then put some text like this onto that page, this seems to happen fairly predictably. In fact, in one case I couldn't get it to NOT happen!

My guess is that the RVEdit side is having a difficult time dealing with the formatting being handed to it. I've also noticed problems when small images are in a Word doc that are centered. They don't import well either, frequently getting displaced to somewhere else on the page into the middle of a paragraph or block of text.

Ditto for images that are too large for the space allocated to them. They don't get shrunk, even though the Word doc does shrink them to fit into a smaller space. The importer doesn't seem capable of dealing with this situation.

(I'm using an app derived from the ScaleRV ActionTest demo.)

-David

Sergey Tkachenko
Site Admin
Posts: 14766
Joined: Sat Aug 27, 2005 10:28 am
Contact:

Post by Sergey Tkachenko » Thu Apr 10, 2008 2:36 pm

Please send problematic doc files to [email protected]

toolwiz
Posts: 150
Joined: Wed Nov 30, 2005 3:27 am

Post by toolwiz » Thu Apr 10, 2008 11:07 pm

Ok, the hyperlink problem has been narrowed down. It's not related.

The image layouts are fairly generic and easy to reproduce. Maybe it's just necessary to put images and text into tables to preserve their layout on a page? I don't know if the layout problem is related to SRV or RV, but documents with images in them don't always import the image layouts properly.

-David

Sergey Tkachenko
Site Admin
Posts: 14766
Joined: Sat Aug 27, 2005 10:28 am
Contact:

Post by Sergey Tkachenko » Thu Apr 17, 2008 4:06 pm

The most probably, the problem with images exists already in intermediate RTF code generated by the converter. Or (less probably) the problem occurs when TRichView loads this RTF code.
To make sure, I need a sample file.

Post Reply