Problem with unitsprogram property

ScaleRichView support and discussion (TRichView add-on for WYSIWYG editing)
Post Reply
prosoft
Posts: 24
Joined: Tue Jul 11, 2006 8:51 am

Problem with unitsprogram property

Post by prosoft » Fri Oct 24, 2008 11:15 am

I create document with millimeter units. I set up page border left=25 mm,(right,top,bottom)=15 mm. I write text and i insert image. Now i do save it to my database by SaveToStream method. Now i loaded it. All is OK.
Now i select all (Ctrl-A) and copy to clipboard and paste to end of document. All is shown right.
Next step is save to stream. When i loaded this document again document units are changed to inches and border (top,bottom)=1, (left,right)=1.25.
I don't know why.
Can you help me?

Thanks Josef.

Sergey Tkachenko
Site Admin
Posts: 14654
Joined: Sat Aug 27, 2005 10:28 am
Contact:

Post by Sergey Tkachenko » Sun Nov 02, 2008 11:26 am

Please post the code how you save and how you load documents.

prosoft
Posts: 24
Joined: Tue Jul 11, 2006 8:51 am

Post by prosoft » Tue Nov 04, 2008 1:08 pm

Load:

FRvfEditor:=TfrRVFEdit.Create(self); //This is TFrame child that contains RV components
FRvfEditor.Align:=alClient;
FRvfEditor.Parent:=self; // self is TPanel
// FrvfEditor.SRichViewEdit1.UnitsProgram is rvuMilimeters
FrvfEditor.SRichViewEdit1.LoadRVFFromStream(AMemStr);
// FrvfEditor.SRichViewEdit1.UnitsProgram is rvuInches

Save:
// FrvfEditor.SRichViewEdit1.UnitsProgram is rvuMilimeters
FrvfEditor.SRichViewEdit1.RichViewEdit.SaveRVFToStream(AmemStr,false);
// FrvfEditor.SRichViewEdit1.UnitsProgram is rvuMilimeters

Sergey Tkachenko
Site Admin
Posts: 14654
Joined: Sat Aug 27, 2005 10:28 am
Contact:

Post by Sergey Tkachenko » Mon Nov 10, 2008 4:15 pm

We cannot reproduce the problem. Please send RVF file to [email protected]

prosoft
Posts: 24
Joined: Tue Jul 11, 2006 8:51 am

Post by prosoft » Tue Nov 11, 2008 9:30 am

I sent email with rvf files.

Zvo.

Sergey Tkachenko
Site Admin
Posts: 14654
Joined: Sat Aug 27, 2005 10:28 am
Contact:

Post by Sergey Tkachenko » Tue Nov 11, 2008 1:46 pm

Not recevied. Please resend to [email protected]

prosoft
Posts: 24
Joined: Tue Jul 11, 2006 8:51 am

Post by prosoft » Tue Nov 18, 2008 8:06 am

I resent it.

Zvo.

Sergey Tkachenko
Site Admin
Posts: 14654
Joined: Sat Aug 27, 2005 10:28 am
Contact:

Post by Sergey Tkachenko » Thu Nov 20, 2008 4:51 pm

This is a trichview bug. When pasting RVF, DocParameters were reset. It will be fixed (DocParameters must not be changed on inserting or pasting).

Post Reply