Testing RVCamera - Video blurred

RVMedia support and discussion (components for displaying and controlling IP cameras, webcams, video conferencing, video chats, recording audio and video files)
ya_vanka
Posts: 16
Joined: Tue Oct 22, 2019 6:24 pm

Re: Testing RVCamera - Video blurred

Post by ya_vanka » Wed Oct 23, 2019 8:10 am

RVMedia supports GStreamer 0.1, not 1.0:
I've read it, but can you explain why? 0.1 is soooooo outdated...

ya_vanka
Posts: 16
Joined: Tue Oct 22, 2019 6:24 pm

Re: Testing RVCamera - Video blurred

Post by ya_vanka » Wed Oct 23, 2019 8:11 am

And do you have any ideas how to solve ffmpeg problem?

Sergey Tkachenko
Site Admin
Posts: 14755
Joined: Sat Aug 27, 2005 10:28 am
Contact:

Re: Testing RVCamera - Video blurred

Post by Sergey Tkachenko » Wed Oct 23, 2019 8:37 am

There are several RVCamera.FFMpegProperty properties that could help.
First, I recommend assigning MaxDelay = 500 000.

ya_vanka
Posts: 16
Joined: Tue Oct 22, 2019 6:24 pm

Re: Testing RVCamera - Video blurred

Post by ya_vanka » Wed Oct 23, 2019 9:31 am

Can't find MaxDelay property in RVCamera.FFMpegProperty

ya_vanka
Posts: 16
Joined: Tue Oct 22, 2019 6:24 pm

Re: Testing RVCamera - Video blurred

Post by ya_vanka » Wed Oct 23, 2019 9:35 am

And is it possible to pass parameters to ffmpeg?

For example I would like to pass -an and -fast parameters (ffplay.exe -an -fast rtsp://:8554/stream.sdp)

Sergey Tkachenko
Site Admin
Posts: 14755
Joined: Sat Aug 27, 2005 10:28 am
Contact:

Re: Testing RVCamera - Video blurred

Post by Sergey Tkachenko » Wed Oct 23, 2019 9:56 am

Current version of RVMedia does not allow to pass arbitrary parameters to FFmpeg, only parameters listed in RVCamera.FFMpegProperty.

MaxDelay must be the second property listed in RVCamera.FFMpegProperty in the Object Inspector.

ya_vanka
Posts: 16
Joined: Tue Oct 22, 2019 6:24 pm

Re: Testing RVCamera - Video blurred

Post by ya_vanka » Wed Oct 23, 2019 10:03 am

MaxDelay must be the second property listed in RVCamera.FFMpegProperty in the Object Inspector.
But it isn't there:
FFMpeg properties.jpg
FFMpeg properties.jpg (37.26 KiB) Viewed 1440 times

Sergey Tkachenko
Site Admin
Posts: 14755
Joined: Sat Aug 27, 2005 10:28 am
Contact:

Re: Testing RVCamera - Video blurred

Post by Sergey Tkachenko » Wed Oct 23, 2019 10:15 am

What version of RVMedia do you use? New version has much more properties there.

ya_vanka
Posts: 16
Joined: Tue Oct 22, 2019 6:24 pm

Re: Testing RVCamera - Video blurred

Post by ya_vanka » Sat Oct 26, 2019 12:39 pm

I used version 6.1

Tried version 7, but cant get video stream. I use VideoRecorder project.
Changed in unit SampleCamList the following line (20):

'alias=CAM 1|' + 'url=rtsp://127.0.0.1:8554/stream.sdp|' + 'host=|' + 'port=|' + 'login=|' +

But I get only message: Video stream error.

What has changed in version 7?
Why can't I get the same video stream that works in 6.1?

Sergey Tkachenko
Site Admin
Posts: 14755
Joined: Sat Aug 27, 2005 10:28 am
Contact:

Re: Testing RVCamera - Video blurred

Post by Sergey Tkachenko » Sat Oct 26, 2019 6:47 pm

Do you have FFmpeg available for the application?
ya_vanka wrote:
Sat Oct 26, 2019 12:39 pm
I used version 6.1

Tried version 7, but cant get video stream. I use VideoRecorder project.
Changed in unit SampleCamList the following line (20):

'alias=CAM 1|' + 'url=rtsp://127.0.0.1:8554/stream.sdp|' + 'host=|' + 'port=|' + 'login=|' +

But I get only message: Video stream error.

What has changed in version 7?
Why can't I get the same video stream that works in 6.1?

ya_vanka
Posts: 16
Joined: Tue Oct 22, 2019 6:24 pm

Re: Testing RVCamera - Video blurred

Post by ya_vanka » Sat Oct 26, 2019 8:43 pm

Yes, I do.
I even placed dlls in the same folder with apllication.

Sergey Tkachenko
Site Admin
Posts: 14755
Joined: Sat Aug 27, 2005 10:28 am
Contact:

Re: Testing RVCamera - Video blurred

Post by Sergey Tkachenko » Mon Oct 28, 2019 5:40 pm

Probably, FFmpeg codec does not like some options specified in RVCamera.FFMpegProperty.
Try assigning RTSPTransport = [rvpeTCP,rvpeUDP]

In the next update, we will add a property to turn off all FFMpegProperty options.

ya_vanka
Posts: 16
Joined: Tue Oct 22, 2019 6:24 pm

Re: Testing RVCamera - Video blurred

Post by ya_vanka » Tue Oct 29, 2019 8:56 am

assigning RTSPTransport = [rvpeTCP,rvpeUDP]
Thanks, this helped!

But why these values are not set by default?

Sergey Tkachenko
Site Admin
Posts: 14755
Joined: Sat Aug 27, 2005 10:28 am
Contact:

Re: Testing RVCamera - Video blurred

Post by Sergey Tkachenko » Tue Oct 29, 2019 1:44 pm

We changed this default value in our working version, so it will be changed in the next update.

panlab_mf
Posts: 30
Joined: Wed Feb 06, 2019 9:55 am

Re: Testing RVCamera - Video blurred

Post by panlab_mf » Thu Oct 31, 2019 2:01 pm

Hi,

I've tried the "test_ffmpeg" to understand what is happening to my project. But, this tool doesn't run with other dll's but the original deployed by you (see attached release note.txt).

Any way, if I run several instances of this testing tool I can see no delay betwen each live streaming cameras. Why is this not working on the rv-ffmpeg multi camera view example?

Thanks,
Attachments
RELEASE_NOTES.txt
(1.39 KiB) Downloaded 22 times

Post Reply