Page 2 of 2

Re: Testing RVCamera - Video blurred

Posted: Wed Oct 23, 2019 8:10 am
by ya_vanka
RVMedia supports GStreamer 0.1, not 1.0:
I've read it, but can you explain why? 0.1 is soooooo outdated...

Re: Testing RVCamera - Video blurred

Posted: Wed Oct 23, 2019 8:11 am
by ya_vanka
And do you have any ideas how to solve ffmpeg problem?

Re: Testing RVCamera - Video blurred

Posted: Wed Oct 23, 2019 8:37 am
by Sergey Tkachenko
There are several RVCamera.FFMpegProperty properties that could help.
First, I recommend assigning MaxDelay = 500 000.

Re: Testing RVCamera - Video blurred

Posted: Wed Oct 23, 2019 9:31 am
by ya_vanka
Can't find MaxDelay property in RVCamera.FFMpegProperty

Re: Testing RVCamera - Video blurred

Posted: Wed Oct 23, 2019 9:35 am
by ya_vanka
And is it possible to pass parameters to ffmpeg?

For example I would like to pass -an and -fast parameters (ffplay.exe -an -fast rtsp://:8554/stream.sdp)

Re: Testing RVCamera - Video blurred

Posted: Wed Oct 23, 2019 9:56 am
by Sergey Tkachenko
Current version of RVMedia does not allow to pass arbitrary parameters to FFmpeg, only parameters listed in RVCamera.FFMpegProperty.

MaxDelay must be the second property listed in RVCamera.FFMpegProperty in the Object Inspector.

Re: Testing RVCamera - Video blurred

Posted: Wed Oct 23, 2019 10:03 am
by ya_vanka
MaxDelay must be the second property listed in RVCamera.FFMpegProperty in the Object Inspector.
But it isn't there:
FFMpeg properties.jpg
FFMpeg properties.jpg (37.26 KiB) Viewed 2653 times

Re: Testing RVCamera - Video blurred

Posted: Wed Oct 23, 2019 10:15 am
by Sergey Tkachenko
What version of RVMedia do you use? New version has much more properties there.

Re: Testing RVCamera - Video blurred

Posted: Sat Oct 26, 2019 12:39 pm
by ya_vanka
I used version 6.1

Tried version 7, but cant get video stream. I use VideoRecorder project.
Changed in unit SampleCamList the following line (20):

'alias=CAM 1|' + 'url=rtsp://127.0.0.1:8554/stream.sdp|' + 'host=|' + 'port=|' + 'login=|' +

But I get only message: Video stream error.

What has changed in version 7?
Why can't I get the same video stream that works in 6.1?

Re: Testing RVCamera - Video blurred

Posted: Sat Oct 26, 2019 6:47 pm
by Sergey Tkachenko
Do you have FFmpeg available for the application?
ya_vanka wrote:
Sat Oct 26, 2019 12:39 pm
I used version 6.1

Tried version 7, but cant get video stream. I use VideoRecorder project.
Changed in unit SampleCamList the following line (20):

'alias=CAM 1|' + 'url=rtsp://127.0.0.1:8554/stream.sdp|' + 'host=|' + 'port=|' + 'login=|' +

But I get only message: Video stream error.

What has changed in version 7?
Why can't I get the same video stream that works in 6.1?

Re: Testing RVCamera - Video blurred

Posted: Sat Oct 26, 2019 8:43 pm
by ya_vanka
Yes, I do.
I even placed dlls in the same folder with apllication.

Re: Testing RVCamera - Video blurred

Posted: Mon Oct 28, 2019 5:40 pm
by Sergey Tkachenko
Probably, FFmpeg codec does not like some options specified in RVCamera.FFMpegProperty.
Try assigning RTSPTransport = [rvpeTCP,rvpeUDP]

In the next update, we will add a property to turn off all FFMpegProperty options.

Re: Testing RVCamera - Video blurred

Posted: Tue Oct 29, 2019 8:56 am
by ya_vanka
assigning RTSPTransport = [rvpeTCP,rvpeUDP]
Thanks, this helped!

But why these values are not set by default?

Re: Testing RVCamera - Video blurred

Posted: Tue Oct 29, 2019 1:44 pm
by Sergey Tkachenko
We changed this default value in our working version, so it will be changed in the next update.

Re: Testing RVCamera - Video blurred

Posted: Thu Oct 31, 2019 2:01 pm
by panlab_mf
Hi,

I've tried the "test_ffmpeg" to understand what is happening to my project. But, this tool doesn't run with other dll's but the original deployed by you (see attached release note.txt).

Any way, if I run several instances of this testing tool I can see no delay betwen each live streaming cameras. Why is this not working on the rv-ffmpeg multi camera view example?

Thanks,