Page 1 of 1

Table columns wrapping text

Posted: Wed Jun 05, 2019 1:57 pm
by McColls
Hi

We have developed an email client using tRichView, HTMLViewer and Clever components. When viewing an email (created in Outlook) the table columns are narrower, resulting in the text being wrapped. We are currently unable to find a way to display the table as intended.

I have attached 2 images showing the source table and how it is displayed in TRichView.

Source Table
SourceTable.png
SourceTable.png (23.03 KiB) Viewed 3584 times
Displayed Table
DisplayedTable.png
DisplayedTable.png (25.6 KiB) Viewed 3584 times
Regards, Pieter

Re: Table columns wrapping text

Posted: Thu Jun 06, 2019 11:36 am
by Sergey Tkachenko
Is this the full window width? Maybe the table is narrower because it is fit to the window width?
Can you send me this document as RVF? To find out what is wrong, I need to know how table and column widths, cell paddings and cell spacings are defined.

Re: Table columns wrapping text

Posted: Thu Jun 06, 2019 2:47 pm
by McColls
No, it is just a screen shot to indicate the difference between viewing in Chrome/IE and TRichView.
I have been able to fix the problem by setting "WordWrap := False" but that sets it for the whole document.

Is there a way to only turn WordWrap off for only tables?

Thanks, Pieter

Re: Table columns wrapping text

Posted: Wed Jul 24, 2019 6:25 pm
by Sergey Tkachenko
I am sorry for overlooking your answer/question.

There is no no-wrap setting for a table or table cell, but there is a setting for paragraphs.

Include rvpaoNoWrap in Options of paragraph style.
If you use RichViewActions for UI, you can use TrvActionWordWrap to switch wrapping on/off for the selected paragraphs.