Installing for ONLY ONE version of Delphi?

General TRichView support forum. Please post your questions here
Post Reply
alogrep
Posts: 52
Joined: Fri Oct 27, 2006 5:25 pm

Installing for ONLY ONE version of Delphi?

Post by alogrep » Sat Oct 19, 2019 2:55 pm

Hi.
Is this possible? I have Delphi 10.2 installed, along with D5. Is it possible to install richview ONLY for 10.2 but not touch the D5 installation at all? If so, how?
Thank you

Sergey Tkachenko
Site Admin
Posts: 14708
Joined: Sat Aug 27, 2005 10:28 am
Contact:

Re: Installing for ONLY ONE version of Delphi?

Post by Sergey Tkachenko » Sat Oct 19, 2019 3:17 pm

When running Setup, just uncheck Delphi 5. Delphi 5 will not be affected.

However:
- when uninstalling, it uninstalls TRichView from all Delphi versions.
- if you run "Install TRichView in Delphi IDE" shortcut in the Start menu and uncheck "Delphi 5", TRichView will be uninstalled from Delphi 5.

alogrep
Posts: 52
Joined: Fri Oct 27, 2006 5:25 pm

Re: Installing for ONLY ONE version of Delphi?

Post by alogrep » Sat Oct 19, 2019 4:05 pm

Hi
Sorry, there is no list of installations to uncheck (D5). I just ran the installation again (and cancelled immediately)
And it does not show anything about "uninstall"
Also I noticed that while running install.exe, in the same folder now there is another file "TRichView18Setup18.0.1.exe". Should perhaps run that executable instead? Or is that just a temporary file used by install.exe?
Thanks

alogrep
Posts: 52
Joined: Fri Oct 27, 2006 5:25 pm

Re: Installing for ONLY ONE version of Delphi?

Post by alogrep » Sat Oct 19, 2019 4:26 pm

OK I solved it. I unselected "install IDE", then i went and executed "IDEInstall.exe" and there appeared the list of installed delphi versions.
Thanks.

Post Reply