Missing icons in ReportBuilder 20.02

General TRichView support forum. Please post your questions here
Post Reply
GoranBru
Posts: 15
Joined: Wed Jan 22, 2020 2:26 pm

Missing icons in ReportBuilder 20.02

Post by GoranBru »

Hello,
I have updated the ReportBuilder from version 19.03 to 22.02 yesterday and after that I reruned the installation for TRichView and I don't see the components for TppRichView and TppDBRichView in the ReportDesigner anymore. To be sure I just reruned the installation and I see in the listbox:
"Installing optional integration in ReportBuilder... Skipped."
What can I do to bring back the components to RB designer? I use RB 20.02, TRichView 19.03 and the TScaleRichView 9.0.3

Best regards,
Goran

Sergey Tkachenko
Site Admin
Posts: 15238
Joined: Sat Aug 27, 2005 10:28 am
Contact:

Re: Missing icons in ReportBuilder 20.02

Post by Sergey Tkachenko »

How did you reinstall TRichView? After a major ReportBuilder update, it's not enough to run "Install TRichView in Delphi IDE" from the Start menu. You need to re-run the full TRichView setup (because it needs to recreate packages for ReportBuilder wrapper for the changed major version of ReportBuilder).

GoranBru
Posts: 15
Joined: Wed Jan 22, 2020 2:26 pm

Re: Missing icons in ReportBuilder 20.02

Post by GoranBru »

Hi Sergey,
I started the application "Install TRichView in Delphi IDE", then selected "Install or modify" and that is it. Should I remove TScaleRichView and then also TRichView and then install both of them?

GoranBru
Posts: 15
Joined: Wed Jan 22, 2020 2:26 pm

Re: Missing icons in ReportBuilder 20.02

Post by GoranBru »

Hi Sergey,
Your question made me thinking so I opened projects RvRbD10_1.dproj and RvRbD10_1_Dsgn.dproj, modified the lines pointing to rbIDE*, rbRCL* and rbRTL* to the correct files (in my case rbIDE2024 etc), rebuild, compiled and installed the later one. Now I have those icons back. Thanks!

GoranBru
Posts: 15
Joined: Wed Jan 22, 2020 2:26 pm

Re: Missing icons in ReportBuilder 20.02

Post by GoranBru »

Hi,
I have a weird situation. The icons in ReportBuilder designer have dissapeared in our big application, just like that, nothing special was done. I sadi okay, let's update TRichView with new version 18.4 and then also TScaleRichView with the latest 9.2 (as per installer) and again, no icons in TppReport. Then I created a new blank project, added ppRichView in the Uses section as in our big application, added TppReport and opened the designer. On my surprise, the icons were there! I saved the project closed all, even Delphi Berlin and restarted our big application and again, no icons. I've tried a few variations of closing/restarting but in big application I can't get icons in the toolbars, in new, empty no problem. Even if I rebuild and start the application and open a hidden designer for reports, I see icons but not in the design time. If I try to open the report with RichView in design time, Delphi complaints. Any ideas?

I use Delphi Berlin Update 2, RB 20.02, DevExpress 18.2.11 etc on Windows 10 Enterprise 2004, build 19041.329. Btw, the RichView 18.4 installer didn't sense the DevExpress, which we have full subscription pack (all features).

Sergey Tkachenko
Site Admin
Posts: 15238
Joined: Sat Aug 27, 2005 10:28 am
Contact:

Re: Missing icons in ReportBuilder 20.02

Post by Sergey Tkachenko »

Do you have ppRichView in "uses" of your application?

Can you update your DevExpress components? We changed our components for compatibility with DevExpress VCL v19.x, and compatibility with v18.x is lost.

GoranBru
Posts: 15
Joined: Wed Jan 22, 2020 2:26 pm

Re: Missing icons in ReportBuilder 20.02

Post by GoranBru »

Hi,
I do have ppRichView unit in all datamodules where reports that use TRichView are loaded. This hasn't changed during the upgrade.
Upgrading ReportBuilder is not an easy job as it has to be done with all guys here and maybe we shall do it during the summer months. Maybe.

Post Reply